Messages récents

Pages: [1] 2 3 ... 10
1
Problèmes/Idées/Suggestions / Re : ô different selon shoutcast et icecast avec API
« Dernier message par web84 le 13 Avril 2019 à 03:52:16 »
Bonjour,

Voici les captures de résultat sur le site :

Le première avec le titre du bas correspond à serveur shoutcast et dans le player Icecast
et le deuxième serveur shoutcast dans les deux cas.

sur api avec shoutcast :
"song_history": {
        "No1": {
            "artist": "ELI ROSE",
            "title": "T\u00c3't ou tard",
            "last_played": "1555141362",
            "covers": {
                "small": "\/\/covers.webradio.tools\/small\/0939dd8d4f4914f99fcc8cdd5a62fb0ba69703e6",
                "medium": "\/\/covers.webradio.tools\/medium\/0939dd8d4f4914f99fcc8cdd5a62fb0ba69703e6",
                "large": "\/\/covers.webradio.tools\/large\/0939dd8d4f4914f99fcc8cdd5a62fb0ba69703e6",
                "extralarge": "\/\/covers.webradio.tools\/extralarge\/0939dd8d4f4914f99fcc8cdd5a62fb0ba69703e6"
            }

sur api sur Icecast
"song_history": {
        "No1": {
            "artist": "ELI ROSE",
            "title": "T\u00f4t ou tard",
            "last_played": "1555141288",
            "covers": {
                "small": "\/\/covers.webradio.tools\/small\/0939dd8d4f4914f99fcc8cdd5a62fb0ba69703e6",
                "medium": "\/\/covers.webradio.tools\/medium\/0939dd8d4f4914f99fcc8cdd5a62fb0ba69703e6",
                "large": "\/\/covers.webradio.tools\/large\/0939dd8d4f4914f99fcc8cdd5a62fb0ba69703e6",
                "extralarge": "\/\/covers.webradio.tools\/extralarge\/0939dd8d4f4914f99fcc8cdd5a62fb0ba69703e6"
            }


2
Problèmes/Idées/Suggestions / Re : ô different selon shoutcast et icecast avec API
« Dernier message par Bahanos le 12 Avril 2019 à 23:19:11 »
L’encodage est un gros problème à régler avec l'API.

Pouvez-vous m'envoyer une capture du résultat sur votre site ?
3
Problèmes/Idées/Suggestions / ô different selon shoutcast et icecast avec API
« Dernier message par web84 le 12 Avril 2019 à 07:23:05 »
Bonjour,

Voici quelques temps que lors qu'un titre ou un artiste se trouve avec un ô, l'affichage est en erreur avec l'API

J'ai deux serveurs : 1 shoutcast encodeur BUTT et 1 icecast encodeur Sound Empire Caster
J'ai déjà inversé les encodeurs par rapport au serveur et j'ai le même souci avec les lettres ô qui sont mal encoder.

Ex . :
"artist": "CALI",
"title": "Jolie m\u00c3'me (radio edit)"

Test réalisé avec UTF-8 : l'api sur les deux serveurs la même erreur.
Test réalisé sans UTF-8 : l'api sur Icecast = Ok mais avec Shoutcast = Non

Les liens des deux serveurs :
http://api.3.5.2.webradio.tools/pollux.shoutca.st:8796/stream
http://api.3.5.2.webradio.tools/5.196.72.136:7002/stream

Je ne vois pas pour quoi alors que les autres caractères fonctionnes sur les deux versions.
4
Problèmes/Idées/Suggestions / Re : Icecast 2 - Current Song / title
« Dernier message par Bahanos le 12 Avril 2019 à 00:53:09 »
Cela ne vient pas du fait qui n'arrive pas a voir la balise "titre"... mais le fait qu’il n'arrive pas a récupéré les metadata's via l'audio envoyer par le serveur...

ex: Si j'essaie ouvrir ce lien "http://stream.freeradioplayer.net:9290/maxfm" dans Winamp ou un autre logiciel qui a besoin des métadonnées ... rien ne ce passe. (Comme si le lien n’était pas valide (non conforme)).

L'API se base sur les métadonnées envoyées via l'audio du serveur.
5
Problèmes/Idées/Suggestions / Icecast 2 - Current Song / title
« Dernier message par mrmazure le 02 Avril 2019 à 07:19:27 »
Salut Bahanos, j’espère que tu vas bien,

Je me remets tout doucement à bricoler sur des Icecast et je me suis rendu compte d'un problème qui impacte l'API title. Certains logiciels radio (comme MB Studio) envoient le titre de la chanson en cours de diffusion via la balise "title" du Icecast, là où d'autres l'envoi sur la balise "Currently playing". Le souci est que l'API ne va chercher que le contenu de la balise "Currently playing" et si elle n'existe pas (ou ne contiens rien) l'API ne va pas chercher le contenu de "Title", je ne sais pas si je suis assez claire dans mes explications ?  ;D

Title : https://freeradioplayer.net/test1/
Currently playing : https://freeradioplayer.net/test2/

Serait-il possible de faire en sorte que l'API aille lire la balise "Title" si "Currently playing" est vide ou absent ?

Merci pour ton boulot,
Thomas





6
Discussion générale / Je suis toujours là !!!
« Dernier message par Bahanos le 16 Mars 2019 à 01:46:05 »
... Oui je ne donne pas souvent de mes nouvelles ... mais je travaille sur un gros projet ses temps si ... et avec le nouveau site de Caramania.Ca ... cela me demande beaucoup de temps ...

Mais je vais bientôt recommencer à travailler sur WebRadio.Tools !!!

... normalement ... cet été si tout va bien ;D
7
Présentation des membres / Re : Salutations :)
« Dernier message par Bahanos le 27 Janvier 2019 à 13:26:51 »
Bienvenue ! :)
8
Présentation des membres / Salutations :)
« Dernier message par Billigradio le 27 Janvier 2019 à 04:47:08 »
Très content d'intégrer ce forum que j'ai découvert il y a quelques minutes seulement :)
Je m'appelle Gael, je vis au coeur de la Bretagne et je développe un concept de webradio axé sur la culture locale, la langue mais le tout pour une cible "jeune_ jeune adulte" et ouverte sur le monde...
Un beau bordel donc :) :) :)

Une webradio 100% virtuelle, pas de studio dans avec une adresse, juste une caisse dans ma voiture ou je me déplace selon les besoins.
Le reste est entièrement virtualisé depuis un VPS de chez Caramania (jamais en panne) et un secours chez Centova (on est jamais trop prudent :) )

Bref, je suis un passionné de radio et je suis toujours avide d'apprendre et de partager.
9
Problèmes/Idées/Suggestions / Re : integration api sur wordpress
« Dernier message par web84 le 11 Janvier 2019 à 12:24:08 »
Bonjour,

Désolé pour le retard de mon coté.

Voici l'adresse https://www.radiorg30.fr

Le problème ne se verra pas car j'ai utiliser le
<script>
var $ = jQuery.noConflict();
</script>
au démarrage du fichier config ou il y a les variables pour interroger votre api

Le problème c'est que vos script utilise encore $(document) au lieu d'utiliser jQuery

Vous pouvez vérifier sur mon site plus de message

Merci encore pour votre réponse.
10
Problèmes/Idées/Suggestions / Re : integration api sur wordpress
« Dernier message par Bahanos le 29 Décembre 2018 à 12:50:50 »
Désoler pour le délai de réponse.

Avez-vous l'adresse de la page ou est génère cette erreur ?
Pages: [1] 2 3 ... 10